3086 0

Настройка коммутаторов D-link, Edge-Core и Dell. Часть 1 (vlan)

По большей части производители делают однотипный синтаксис управления своими коммутаторами. То есть настроив одну модель D-link другая едва ли будет чем-то отличаться. Рассмотрим настройку коммутаторов от производителей D-link, Edge-Core и Dell.

Подключение к коммутаторам

В windows наиболее удобно подключиться можно будет с помощью PuTTY.
Для удалённого доступа будем использовать telnet.

Настройка подключения в PuTTY
Serial line: COM3 (зависит от порта на котором у вас RS-232, смотреть в Диспетчер устройств>Порты (COM и LPT) > USB-SERIAL CH340)
Connection type: serial
Speed: 9600 (в некоторых случаях 115200, например для D-link)

В компонентах вкдючить telnet для консоли cmd.
telnet 192.168.0.1 #Подключаемся telnetом к удалённому коммутатору

В linux можно использовать стандартную консоль, если сложно, тогда ставьте PuTTY.
dmesg | grep ttyUSB #Ищем где у нас подключен RS-232
sudo chmod 666 /dev/ttyUSB0 #Меняем права на интерфейс
sudo chmod 777 /dev/ttyUSB0
/dev/ttyUSB0 115200 #Подключаемся к коммутатору со скоростью 115200(D-Link)

Альтернативные программы linux:
screen /dev/ttyUSB0
cu /dev/ttyUSB0 -s 115200

D-link (на примере DES-3200-26)

Shift+6 – Password recovery mode для сброса пароля или учётки админа
reset account – Сброс учётки
reset config – Сброс конфигурации

show ipif #Смотрим основной конфиг ip, VLAN name ...
show vlan #Смотрим vlanы, так же покажет таггеды, антаггеды
show account #Смотрим пользователей
create account admin baduser #Создаём пользователя baduser с правами админа
delete account userOld #Удаление старого пользователя userOld
create vlan vlanid 1050,1051,101-240 #Создаём vlanы и/или группы vlanов
create vlan 1024 tag 1024 #Альтернативноле создание vlan
config vlan vlanid 101 name MGM	#Присваиваем имя MGM для управляющего, 
				#внашем случае, vlan 101
config ipif System vlan MGM #Назначаем управляющий vlan чрез имя
config ipif Sysyem ipaddress 192.168.201.22/24	#Задаём ip на комутатор 
						#(/24 иногда 255.255.255.0)
config vlan vlanid 1050 add untagged 1-24 #Вешаем vlan 1050 на порты 1-24 через id
config vlan 1050 add untagged 1-24 #Вешаем vlan 1050 на порты 1-24 через VLAN Name
config vlan vlanid 1 delete 1-26 #Убираем vlan с портов
delete vlan vlanid 1051 #Удаление влана
create iproute default 192.168.201.1 #Зажаём шлюз, если нужно указать.
save #Сохраняем конфиг

logout #Выход
reboot #Перезагрузка

? – даёт подсказки.
Удалять клавишей Backspace перед курсором.
Стек настраивается сзади, подключается и настраивается как одна.
vlan 1 лучше с портов почистить.

Edge-Core (на примере ES3528M)

Сброс – ctrl+u, важно нажать в самом начале загрузки
Затем ввести пароль: mercury
Удаляем startup1.cfg (жмём d и пишем название нужного файла – startup1.cfg)
подтвержаем – y
Выходим – q
После сброса логин\пароль – admin\admin

Чтобы смотреть информацию нужно точно не находиться в configure.

show ip interface #Смотреть основной конфиг ip, VLAN name ...
show log ram		#Смотреть лог
show vlan #Смотрим vlan
show user #Смотреть пользователей
show startup-config #Подробная инфа о конфиге
show running-config #Подробная инфа о конфиге
show interfaces switchport ethernet 1/2	#Смотреть инфу по порту 
					#((t)таггед, (u)антаггед), нативный.
configure #Входим в режим конфигуратора
   username baduser access-level 15 #Настройка админской(15) учётки baduser
   username baduser password 0 hardpass #Задание пароля hardpass
						#(0 - без шифрования, 7 - с шифрованием)
   no username admin #Удалить учётку admin
   vlan database #Заходим в меню управления вланами (созд, удаление)
      vlan 101 name MGM media ethernet state active #Создадим vlan 101 с им. MGM
      vlan 1050 media ethernet state active #Создадим vlan 1050
      no vlan 106 #удаляет vlan 106, нужно предварительно отвязать от портов
      exit #Выходим из конфигугирования database
   interface ethernet 1/25-28 #Настраиваем vlanы в tagged на порты 25-28
      switchport allowed vlan add 101 tagged
      switchport allowed vlan add 1050 tagged
   interface ethernet 1/1-24 #Настраиваем vlan в untagged на порты 1-24
      switchport allowed vlan add 1050 untagged
      switchport allowed vlan remove 1 #Убираем с портов vlan 1
      # пока другой не присвоен не убирается
   interface ethernet 1/1-24	#Смена режима портов если со старту 
				#настроили не правильно
      switchport mode access #Режим портов untagged
   interface ethernet 1/25-28
      switchport mode trunk #Режим портов tagged
   interface vlan 101 #Меню настройки конкретного влана
      ip address 192.168.201.22 255.255.255.0 #Задаём ip на комутатор
      no ip address #Удаляем ip на комутатор

   ip default-gateway 192.168.201.1 #Шлюз, если нужо задать
   exit #Выход на пункт назад
   end #Выходит в самое начало конфигурирования

copy running-config startup-config	#Сохранение конфига 
					#(работает после выхода из configure)
reload #Перезагрузка
quit #Выход

Если MAC адреса идут на vlan 1, значит нужно настроить нативный влан на юзерский. Если vlan не удаляется с портов – значит он является нативным, нужно сначала сделать нативным другой vlan.

interface ethernet 1/1-24 #Выбор интерфейсов для работы
switchport allowed vlan add 1050 untagged #Проброс untagged vlan
switchport native vlan 1050 #Присваиваем нативный vlan

Протестировать длину кабеля (подскажет на каком метре обрыв).

test cable-diagnostics tdr interface ethernet 1/2    #Выполнить тест на порту 2
show cable-diagnostics tdr interface ethernet 1/2 #Результаты теста на порту 2

Dell (на примере PowerConnect 3424)

enable #перейти в режим управления c > на #
show vlan #Смотрим vlanы
show ip interface #Смотреть основной конфиг ip, VLAN name ...
show user accounts #Смотреть пользователей
show interfaces switchport ethernet 1/g1 # Смотреть информацию по порту таггеды
show log		#Смотреть лог
dir #Смотрим файлы
delete startup-config #Удаляем файл конфигурации (startup-config)
configure #Входим в режим конфигуратора
   no logging console #Отключение логирования в консоль
   hostname del-training #Имя коммутатора в сети (не обязательно)
   username badmin level 15 #создаём админа badmin
   username badmin password пароль #Задаём пароль на badmin
   no username admin #Удаление пользователя admin
   vlan database #Заходим в меню управления вланами (созд, удаление)
      vlan 101 #Создадим vlan 101
      vlan 1022 #Создадим vlan 1022
      no vlan 1021 #Удаляет vlan 1021
      exit #Выход на пункт назад
   interface range ethernet g1-2 #Настройка G1, G2 портов 
                                 #(если не понимает то 1/g1-2)
   switchport mode trunk #G1 G2 в таггед
   switchport trunk allowed vlan add 101 #101 в таггед
   switchport trunk allowed vlan add 1021 #1021 в таггед
   interface range ethernet e1-24 #Задаём диапазон портов ( 1/e1-24)
   switchport mode access #Все порты антаггед
   switchport access vlan 1021 #Портам с заданным диапазоном присваиваем 1021
   interface vlan 101
   name имя_nlan #Задаём имя vlan 101
   no ip address #Удалить ip, пока старый назначен, новый не присвоится
   ip address 192.168.201.22 /24 - задаём ip на коммутатор
   copy running-config startup-config #Сохраняем настройки
   exit #Выход на пункт назад
   end #Выходит в самое начало конфигурирования

Создать учётку администратора, иначе удалённо не пустит.
В стеке порты подключаются наискось, переключение в стек через бут меню.
Во время загрузки ESC, настройка стеков (Stack menu), здесь можно посмотреть текущий номер стека, и задать свой. А можно во время индикации первого стека кнопкой селект выбираешь второй селект, и всё автоматически настроится. После настройки не забыть в бутменю выставить 0 или будет в веб морде отображаться не полностью и в длину. удалять заливать файлы, тоже через бут меню.

RELATED ARTICLES

LEAVE YOUR COMMENT

Your email address will not be published. Required fields are marked *




Скоро останутся лишь две группы работников: те, кто контролирует компьютеры, и те, кого контролируют компьютеры. Постарайтесь попасть в первую.

technicscoffee.com

Если вас как и меня интересуют: Linux, фантастика, технологии, игры и фильмы данных тематик, добро пожаловать на мой более развлекательный ресурс!

Категории